Chapitre 4. Comment suivre les mises à jour de votre Debian GNU/Linux ?

Table des matières
1. Description
2. Pré-requis
3. Installer
4. Utiliser
5. Désinstaller
6. Annexe

Tableau 4-1. Evolution de cet article

DateAjout(s) / Modification(s)
28 juillet 2003Version initiale.
27 octobre 2003Relecture.

1. Description

Lors de la mise à jour de votre Debian GNU/Linux à l'aide de l'outil APT, des paquets sont automatiquement installés sur votre système et vous ne savez pas ce qui a été mis à jour. Si vous n'êtes pas chez vous par exemple et que votre système se met à jour tous les soirs, il peut-être intéressant d'avoir un suivi de ces modifications.

2. Pré-requis

2.1. Pré-requis logiciel

Vous devez avoir un serveur de messagerie installé sur votre machine pour recevoir les modifications qui ont été effectuées sur votre système.

3. Installer

Nous allons installer le paquet apt-listchanges :
# apt-get install apt-listchanges

Une fois le paquet installé, vous devez répondre aux questions suivantes:

Tableau 4-2. apt-get install apt-listchanges

Nom du paquetQuestionRéponse à choisir
apt-listchangesHow should changelogs be displayed with apt / Comment le journal des changements doit il être communiqué ?mail / courrier
apt-listchangesShould apt-listchanges skip changelogs that have already been seen? / Ignorer les changements déjà affichés ?Yes / Yes
apt-listchangesTo whom should apt-listchanges mail changelog entries? / Adresse où envoyer les journaux des changementsIndiquer un compte local de votre machine ou une adresse e-mail externe vers lequel votre serveur de mail local va délivrer les changements.

4. Utiliser

apt-listchanges se lance automatique lors de la mise à jour de votre Debian GNU/Linux. Vous pouvez le déclencher par exemple en récupérant la liste des derniers paquets disponibles pour votre Debian GNU/Linux et en mettant ensuite à jour les paquets trop anciens de votre système. Pour cela :

# apt-get upgrade && apt-get update -u -y

5. Désinstaller

# apt-get remove apt-listchanges

AstuceSupprimer toute trace du package précédement installé
 

Lorsque vous décidez de retirer un package de votre Debian GNU/Linux APT n'efface par les fichiers de configuration de ce package. Ceci permet de réinstaller plus rapidement la package. Cependant si vous souhaitez faire table rase et ne plus entendre parler du package, vous pouvez ajouter l'option --purge lors de la suppression.
# apt-get remove --purge <package>

Si vous souhaitez retirer tous les composants qui ont été installés par le paquet phpmadmin :

# apt-get remove python, apt, python-apt, debconf, ucf

AstuceSupprimer toutes les dépendances d'un package précedement installé
 

Un package (père) a souvent besoin d'autres packages pour pouvoir fonctionner correctement. Ces nouveaux packages forment les dépendances du package père. Cependant d'autres packages peuvent avoir des dépendances similaires. Lorsque vous décidez de retirer tous les dépendances d'un package de votre Debian GNU/Linux vous risquez de rendre votre système instable. Pour ne pas avoir ce problème, vérifiez que la commande APT n'efface pas d'autres packages que ceux que vous avez spécifié. Comme dans l'exemple ci-dessous :
# apt-get remove apt
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
  apt apt-utils base-config
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
  apt
0 packages upgraded, 0 newly installed, 3 to remove and 17  not upgraded.
Need to get 0B of archives. After unpacking 3183kB will be freed.
You are about to do something potentially harmful
To continue type in the phrase 'Yes, do as I say!'

6. Annexe

6.1. Exemple de journal de changements généré par apt- listchanges

Voici un extrait d'un mail que vous pouvez recevoir de la part d'apt-listchanges

apt (0.5.6) unstable; urgency=low

  * Adam Heath <doogie@debian.org>
    - Fix segfault when handling /etc/apt/preferences.  Closes: #192409.
  * Matt Zimmerman <mdz@debian.org>
    - Clean up some string handling, patch from Peter Lundkvist
      <p.lundkvist@telia.com> (Closes: #192225)
    - Don't fall off the end of the buffer when comparing versions.
      Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
    - Minor fixes to apt-ftparchive(1) (Closes: #118156)
    - Fix typo in apt-ftparchive help text (Closes: #119072)
    - More typos in apt-ftparchive help text (Closes: #190936)
    - Update config.guess, config.sub to latest versions
    - Modify the description for apt-utils to reflect the fact that it is not
      (any longer) infrequently used (Closes: #138045)
    - Make setup script for dselect method more explicit about
      overwriting sources.list (Closes: #151727)
    - Fix typo in apt-cache(8) (Closes: #161243)
    - Remove duplicate 'showpkg' from synopsis on apt-cache(8)
      (Closes: #175611)
    - Document in apt-get(8) the meaning of the '*' in ShowList, which is that
      the package is being purged (Closes: #182369)
    - Fix extra "/" character in apt.conf(5) (Closes: #185545)
    - Fix typo in tar error message (Closes: #191424)
    - Clarify description of 'search' on apt-cache(8) (Closes: #192216)
    - Fix incorrect path for 'partial' directory on apt-get(8)
      (Closes: #192933)
    - Fixes to pt_BR translation from Andre Luis Lopes <andrelop@ig.com.br>
      (Closes: #196669)
    - Updated apt_preferences(5) man page with many corrections and
      clarifications from Thomas Hood <jdthood@yahoo.co.uk>
      (Closes: #193336)
    - Fix SGML validation errors in apt-cache.8.sgml introduced in 0.5.5 or so
    - Add a simple example to apt-ftparchive(1) (Closes: #95257)
    - Add bug script for collecting configuration info (Closes: #176482)

 -- Matt Zimmerman <mdz@debian.org>  Mon, 21 Jul 2003 01:59:43 -0400

base-files (3.0.9) unstable; urgency=low

  * Prevent OSNAME from having the GNU/ prefix twice (Closes: #200741).
  * Updated LGPL-2.1 from ftp.gnu.org. Instead of form feeds, the old
    version was using `^' followed by `L' (Closes: #201867).

 -- Santiago Vila <sanvila@debian.org>  Mon, 21 Jul 2003 19:25:12 +0200

squid (2.5.3-4) unstable; urgency=low

  * Switch to gettext for debconf templates (Closes: #202271)
  * debian/control
    - Added Build-Depend on po-debconf
  * debian/rules
    - Handle templates merging
  * debian/po/
    - Moved translations from debian/templates (via debconf-gettextize)
  * debian/po/fr.po
    - Added French template translation (Closes: #202272)

 -- Luigi Gangitano <luigi@debian.org>  Mon, 21 Jul 2003 16:20:31 +0200